[Free-RTC] [Outreachy]

Urvika Gola urvika.gola at gmail.com
Thu Oct 13 05:40:36 CEST 2016

Hi Daniel,
I tried running it , My learnings through out are givenstepwise below after
going through BUILD.txt in

*Prerequisite :*1. Downloaded Gradle 2.2.1 and adding its environment
C:\Users\urvik>gradle -v

Gradle 2.2.1

*To build the project from the command line:*

I cloned "lumicall" into a folder "abc" which I created.
*urvik at DESKTOP-56TSQGT MINGW64 ~/desktop/abc*
*$ git clone https://github.com/opentelecoms-org/lumicall.git
Cloning into 'lumicall'...
remote: Counting objects: 9709, done.
remote: Total 9709 (delta 0), reused 0 (delta 0), pack-reused 9709
Receiving objects: 100% (9709/9709), 22.84 MiB | 602.00 KiB/s, done.
Resolving deltas: 100% (5644/5644), done.
Checking out files: 100% (390/390), done.

a. Fetching the submodules :
urvik at DESKTOP-56TSQGT MINGW64 ~/desktop/abc/lumicall (master) *$ git
submodule init*
Submodule 'jni' (https://github.com/opentelecoms-org/codecs.git) registered
for  path 'jni'

urvik at DESKTOP-56TSQGT MINGW64 ~/desktop/abc/lumicall (master)
*$ git submodule update*
Cloning into 'C:/Users/urvik/Desktop/abc/lumicall/jni'...
Submodule path 'jni': checked out '0db2f6135ce354faf3746e05c1ee1008a2fab8d7'

before cloning I tried downloading the lumicall project and then extracted
the folders and when I was performing these commands, no submodules were
fetched and the jni folder was empty. Later on I tried the cloning method
which worked.

2. To build the JNI code using NDK build tool, which is a tool through
which we can use C, C++ code in our android project. (.cpp files in jni
 Initially I installed NDK through android studio along with Cmake and LLDB.
$ ${NDK_HOME}/ndk-build didnt work --
urvik at DESKTOP-56TSQGT MINGW64 ~/desktop/abc/lumicall (master)
$ C:/Users/urvik/AppData/Local/Android/Sdk/ndk-bundle/ndk-build
bash: C:/Users/urvik/AppData/Local/Android/Sdk/ndk-bundle/ndk-build: No
such file or directory

Later on I downloaded NDK Zip Folder and then executed
k at DESKTOP-56TSQGT MINGW64 ~/desktop/abc/lumicall (master)
*$ C:/Users/urvik/android-ndk-r13/build/ndk-build*
ERROR: Cannot find 'make' program. Please install Cygwin make package
or define the GNUMAKE variable to point to it.

I installed the Cvgwin make pakage,
urvik at DESKTOP-56TSQGT ~
$ make -v
GNU Make 4.1

I tried a lot resolving this but I am unable to do so.
Could you please guide me through.
Thank you
*- Urvika Gola*

On Thu, Oct 13, 2016 at 12:25 AM, Daniel Pocock <daniel at pocock.pro> wrote:

> On 12/10/16 20:32, Urvika Gola wrote:
> > Hi Daniel,
> > Thank you for reverting back.
> > Yes, I know Pranav, I discussed outreachy with him and he guided me.
> > My strongest skills are java and android development among those set of
> > languages.
> >
> Great, please fork Lumicall in Github, try to compile it and tell us
> what happens, any problems you encounter, etc
> _______________________________________________
> Free-RTC mailing list
> Free-RTC at lists.fsfe.org
> https://lists.fsfe.org/mailman/listinfo/free-rtc
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.fsfe.org/pipermail/free-rtc/attachments/20161013/115cac3b/attachment.html>

More information about the Free-RTC mailing list